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1 Introduction 

This user manual describes the software and hardware features of the Time Machine II (or Time 
Machine) a portable kit designed for programming SiTime field programmable (FP) oscillators. The Time 
Machine supports many SiTime oscillators with specialized socket cards that accommodate different 
package sizes. 
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2 Important Notes 

 Refer to the disclaimer section for terms and conditions governing the use of the Time Machine 
II and devices programmed on the Time Machine II. 

 After programming, place samples into an antistatic bag clearly marked "Engineering Samples." 

 Samples can only be programmed using specific field programmable (FP) parts for a given 
oscillator family. See the FP Oscillator datasheet for more information on how to select and 
order FP parts. 

 Please contact your SiTime sales representative for large volume production orders. 

 The Time Machine II has not been tested for EMC compliance, EMI radiation susceptibility, or 
any temperature and humidity cycling. The recommended temperature range is 20°C to 35°C. 

3 Time Machine II Kit Contents 

The Time Machine II kit contains the following items: 

1. SiTime programmer (1 pc) 

2. Socket cards: 

The Time Machine II comes with three different socket cards. Each adapter board includes two 
or more sockets for connecting devices in different packages to the main unit for programming. 
It is possible to remove and insert devices in the socket while the board is connected to the 
SiTime Programmer. 

3. USB cable (1 pc) 

4. Quick start guide (Download)   

5. Samples kit with several devices  

(The enclosed device types may vary; please contact Sales for additional units) 

6. Tweezers for handling small devices  

 

Figure 1. Time Machine II base unit
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 Figure 2. Time Machine socket card SiT6160DK.  
Supports 5.0 mm x 3.2 mm (4-pin and 6-pin) and 7.0 mm x 5.0 mm (4-pin and 6-pin) packages. 

 

 

Figure 3. Time Machine socket card SiT6161DK.  
Supports 2.0 mm x 1.6 mm (4-pin) and 2.5 mm x 2.0 mm (4-pin) packages. 

 

 

 

Figure 4. Time Machine socket card SiT6165DK.  
Supports SOT23-5 package (5-pin) and 3.2 mm x 2.5 mm (4-pin and 6-pin) packages. 

 

4 Additional Socket Cards 

In addition to the three socket cards SiT6160DK, SIT6161DK and SiT6165DK shipped with the kit, the 
following socket card is available. Please contact sales support for availability. 

 

 
Figure 5. Time Machine socket card SiT6166DK.  

Supports 5.0 mm x 3.2 mm (10 pin) package and DIP14 socketed interposers. 

Part outline 
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5 Software Installation 

Scroll to the bottom of the MEMS Oscillator Programmer webpage to find downloadable software and 
download the latest version of the Time Machine software.  Follow the onscreen instructions.  
 

6 Hardware Connection 

Connect the SiTime Programmer to your PC using the USB cable. The power light will illuminate. 

The first time the SiTime Programmer is connected, the Windows Found New Hardware notification will 
appear. Please wait until driver installation is completed. 

 

7 Driver Installation 

The first time the software is launched, driver installation will be required. Time Machine software will 
install all required drivers automatically. 

 

The Windows Security notification window will appear. Please check Always trust software from “sitime 
corp” and click the Install button. 
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8 Working with the Time Machine Software 

Starting the software launches the main user interface (UI) as shown below. 

 

 
 
 
 
 
 
 
 
 
 
 
 

Additional options 
 

Part Number field 

General software help 

Channel 1 

Channel 2 

Tracking ID field 

Part Number Generator button Datasheet button Program button 

Message window 

Operation indicator Device status 
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8.1 User Interface Features 

The following features are available in the main UI: 

- TimeMachine > View Logs – launches the log viewer 

- TimeMachine > Auto Detect – enables/disables parts auto detection mode 

- TimeMachine > Settings – launches available part families configuration 

- TimeMachine > Exit – quits the software 

- Help > View Manual – opens this user manual 

- Help > Supported Devices – shows the list of devices supported by the Time Machine 

- Help > Get Support – opens your email client with a draft of support request email 

- Help > Check for Updates – checks for software updates (requires internet connection) 

- Help > About - SW/FW versions,  
only SW version is shown if the SiTime Programmer is not connected 

- Device status – shows status of the SiTime Programmer (Connected/Disconnected) 

- Operation indicator – indicates operation status and results (READY/BUSY/PASS/FAIL) 

- Message Window – reflects operation result and part detection result 

The main UI can run with or without the SiTime Programmer connected to the host computer. 
This allows you to view the programming log history and get software updates without connecting the 
base unit. 
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8.2 Entering the Part Number 

You may type the SiTime part number into the Part Number Field or copy it from another source and 
paste. 

 
 
 
 
 
 

 

If you enter a valid SiTime Part Number, the background of the Part Number Field becomes green. The 
background will turn red when the part number is invalid. You cannot program the device with an invalid 
part number. 

 

 

 

*   Time Machine II software will alert you with this icon if the part you are trying to program contains 
non-default drive strength. 

**  With the correct part number in the Part Number Field, Time Machine II software will automatically 
detect which FP (field programmable or “blank”) device you will need to use to program that part 
number. If you hover over the FP icon, a box with the blank part number will appear. More details on 
FP parts may be found in the FP Oscillator datasheet. 
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8.3 Part Number Generator 

The Part Number Generator provides an option for generating SiTime part numbers.  

Click the Part Number Generator button on the appropriate channel.  

Note that you should have a valid FP part in the specific channel socket where you enter the part 
number. The PN generator window will appear. 

 

Select the desired part family from the drop down list at the top of the Part Number Generator window.  

Specify the desired frequency and other configuration parameters and click OK.  

The generated part number will be automatically pasted into the Part Number field of the appropriate 
Channel. The Cancel button returns you to the Channel view without updating the Part Number field. 
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8.4 Part Programming 

Once you have entered a valid part number, click the Program button to program the part. The 
programming process result will be reflected in the output window as shown below. 

 
 

If part programming is successful, the operation indicator field will show a green  PASSED  indicator. 
If the part programming fails, the operation indicator field will show a red  FAILED  indicator. In this 
case, see the "Programming generates a FAIL message" section of this manual for information on 
how to proceed. Part verification is done automatically following any programming operation. 

During the programming and verification procedures, the active channel window will dim and all 
controls in the channel dialog boxes will be disabled. The operation indicator will read BUSY as 
shown below. 

 

 

8.5 Tracking ID 

The main UI includes an optional Tracking ID field to help you track programming history.  After entering 
the part number but before programming, you may enter a text string to be associated with the part. 
This Tracking ID will then be displayed after programming in the Logs viewer window. 

8.6 Auto Detect Mode 

To enable auto detect mode, click TimeMachine > Auto Detect. The check mark will be displayed 
indicating that auto detect mode is enabled. In auto detect mode with the SiTime programmer 
connected, the software will automatically check for the presence of a part in each channel and display 
an individual channel view for the appropriate channel. An appropriate message will be displayed in the 
Message Window whenever an FP part is detected. 

Auto detect mode can be used for part frequency estimation. If an already programmed part is inserted 
in the socket, the message will display the estimated part frequency. 
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Note: Auto detect estimated frequency measurement result should not be used to determine part 
performance. 

 

8.7 Viewing Operation Logs 

The Time Machine stores records of all parts programmed. You can access records at any time to 

view programming history. To launch the Log Viewer, select TimeMachine > View Logs on the main 

UI. 
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8.8 Data Log Mode 

Data log mode allows storing additional information about programmed parts and order during batch 
programming. To switch to the data log mode, select View > Data Log as shown in the figure below. 

 
 

The Data Log Utility has fields for entering ordering information, operator lot information, and part 
number. Fields marked with a red asterisk are mandatory. Once required information is entered, it is 
possible to start a programming session. 

 

Operator name 

Quantity of parts to be 
programmed 

Lot ID 

Operation selection 

Channel selection 

Sample request number 

Part number field 

Customer FP part number 

Message window 

Mean part programming 
time 

Session start time 

Quantity of  
processed parts 

(programmed + failed) 

Device status 

Session start button 

Session end time 

Session yield Operation indicator 
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At the beginning of a programming session, the Part Number Generator appears showing the decoded 
part number. After clicking OK in the Part Number Generator window, programming of the first part 
starts. When part programming is complete, the operator should place a new FP part into the socket 
and click the Program Next button. The programming session ends when number of programmed parts 
reaches the Actual Quantity entered or the Stop button is clicked. Programming information is recorded 
and stored in the log at the end of the programming session. 

 

 

8.9 Viewing Data Logs 

Data logs can be displayed by opening the Log Viewer (TimeMachine > View Logs) and selecting the 
Data Log tab. 
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9 Firmware Updates 

The Time Machine may require a firmware update. You will be prompted to apply it during the software 
launch or when you connect the device. 

 

 

It is strongly recommended that you perform an update immediately. 

Do not close the application until the update process is complete. The FW update process will start 
after clicking OK. 

 

 

 

Note: 

The Windows Found New Hardware notification may appear during the firmware update. In this case, 
wait until driver installation is complete. 
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10 Software Updates 

The software will occasionally check for availability of a new software version. This feature requires an 
internet connection. You can check for updates manually at any time by clicking Help > Check for 
Updates under the menu. 

 

 

 
If a software update is available, click Yes to download the update. The installation will start 
automatically after finishing the download process. You will also be notified if your Time Machine 
software is up to date. 
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11 Troubleshooting 

Several common issues may occur while using the Time Machine. This section describes how to address 
these issues. 

11.1 The Time Machine Fails to Start 

Download the Time Machine software from the SiTime web site: Time Machine II webpage and reinstall 
the software. 

11.2 Programming Generates a FAIL Message 

Make sure you are using an appropriate Field Programmable (FP) part in the correct socket and that part 
has not been programmed already. If these conditions are met and programming fails, try replacing the 
device. 

12 Reporting a Bug 

Time Machine has an automatic crash report sending feature. If the system crashes, please send a 
report to SiTime and provide any additional information to help us to analyze and resolve the issue. 

 

 

If you find a bug that does not cause the program to crash or have other feedback, please contact SiTime 
at TimeMachineSupport@sitime.com. Please follow the troubleshooting recommendations in this 
section before reporting an issue. 
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13 Disclaimer 

1. The Time Machine II Programmer and associated hardware (henceforth Platform) are intended 
for use only with SiTime's MEMS oscillators. This Platform will not program any other 
manufacturer's programmable oscillators and no attempt to do so should be made. 

2. The Platform is intended for use for engineering development and evaluation of SiTime's MEMS 
oscillators. SiTime does not guarantee or warranty the devices that are programmed on this 
Platform for qualification or production purposes. 

3. The Platform should be used in static free environment with good engineering practices. 

4. This Platform does not fall under the scope of the European Union directives regarding 
electromagnetic compatibly, FCC, CE or UL and therefore may not meet the technical 
requirements of these directives. 

5. THE PLATFORM AND ITS ACCOMPANYING SOFTWARE AND DOCUMENTATION ARE PROVIDED 
ON AN "AS-IS" BASIS, "WITH ALL FAULTS", AND WITH NO WARRANTY WHATSOEVER. SITIME 
AND ITS LICENSORS EXPRESSLY DISCLAIMS ALL WARRANTIES, WHETHER EXPRESS, IMPLIED 
OR STATUTORY, INCLUDING WITHOUT LIMITATION ANY WARRANTIES OF 
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE, AND NON-INFRINGEMENT. 
SITIME DOES NOT WARRANT THAT USE OF THE PLATFORM (OR ITS ACCOMPANYING 
SOFTWARE) WILL BE UNINTERRUPTED OR ERROR-FREE OR THAT DEFECTS WILL BE 
CORRECTED OR THAT THE PLATFORM (OR ITS ACCOMPANYING SOFTWARE) ARE FREE OF 
VIRUSES OR OTHER HARMFUL COMPONENTS. 

6. The user assumes all responsibility and liability for [the] proper and safe handling of the 
Platform and the associated programmed MEMS oscillators. 

7. The user indemnifies SiTime from all claims arising from the handling or use of this Platform and 
the associated field programmable devices. 

8. Please contact a SiTime representative if you have any issues or problems with using this 
Platform. 

file:///C:/Users/olenas/Desktop/SiTime%20DTP/Product%20Briefs/Application%20notes/www.sitime.com
https://www.sitime.com/contact-sales


  

 

 

TMII UM Rev. 2.12 Page 17 of 17 www.sitime.com 

 

 

Time Machine II User Manual 

Table 1. Revision History 

Version Release Date Change Summary 

2.12 07/24/2019 Added SiT6166DK socket card information 

Other miscellaneous edits for clarity 
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